The documentation for Plume.
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 

1.0 KiB

title
Installing native dependencies

In order to be installed and to work correctly, Plume needs:

  • Git (to get the code)
  • Curl (for RustUp, the Rust installer)
  • GCC and make (to compile C dependencies)
  • PostgreSQL or SQlite 3 development files (for the database)
  • GetText (to manage translations)
  • Rust and Cargo (to build the code)
  • OpenSSL and OpenSSL librairies (for security)
  • pkg-config (for openssl-sys compilation)

Depending on your operating system, the commands to get all these dependencies are not the same, so we need to know what is installed on your machine to guide you: