#815 Check for duplicate deps

Open
opened 3 months ago by kiwii · 1 comments
kiwii commented 3 months ago
As explained here: https://github.com/LemmyNet/lemmy/issues/1054
kiwii added the
A: Meta
label 3 months ago
kiwii added the
C: Enhancement
label 3 months ago
igalic commented 3 months ago
Owner

currently, even attempting to run cargo outdated results in a dead-lock:

error: failed to select a version for `data-encoding`.
    ... required by package `serde_qs v0.6.1`
    ... which is depended on by `plume v0.4.0 (/tmp/cargo-outdatedAW9Bld)`
versions that meet the requirements `^2.2.1` are: 2.3.0, 2.2.1

all possible versions conflict with previously selected packages.

  previously selected package `data-encoding v2.1.1`
    ... which is depended on by `rocket_csrf v0.1.0 (https://github.com/fdb-hiroshima/rocket_csrf?rev=29910f2829e7e590a540da3804336577b48c7b31#29910f28)`
    ... which is depended on by `plume v0.4.0 (/tmp/cargo-outdatedAW9Bld)`

failed to select a version for `data-encoding` which could resolve this conflict
currently, even attempting to run `cargo outdated` results in a dead-lock: ``` error: failed to select a version for `data-encoding`. ... required by package `serde_qs v0.6.1` ... which is depended on by `plume v0.4.0 (/tmp/cargo-outdatedAW9Bld)` versions that meet the requirements `^2.2.1` are: 2.3.0, 2.2.1 all possible versions conflict with previously selected packages. previously selected package `data-encoding v2.1.1` ... which is depended on by `rocket_csrf v0.1.0 (https://github.com/fdb-hiroshima/rocket_csrf?rev=29910f2829e7e590a540da3804336577b48c7b31#29910f28)` ... which is depended on by `plume v0.4.0 (/tmp/cargo-outdatedAW9Bld)` failed to select a version for `data-encoding` which could resolve this conflict ```
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.